Користувальницькькі налаштування

Налаштування сайту


Сайдбар

SiteBar

merezhi:mikrotik:bazove_nalashtuvannja_z_komandnogo_rjadka

MikroTik базове налаштування з командного рядка

Етапи налаштування

  1. Змінити ім'я
  2. Якщо ір статичний - вимкнути dhcp
  3. Якщо налаштування динамічні - увімкнути dhcp
  4. Прописати статичні налаштування
  5. Прописати маршрут по замовчуванню
  6. задати адресацію на клієнтському інтерфейсі
  7. Задати пул адрес, що будуть присвоюватись клієнтам
  8. Запустити dhcp сервер на відповідному інтерфейсі
  9. прописати маскарад

Змінити ім'я

system identity set name=NAME

Вимкнути dhcp

ip dhcp-client set numbers=0 disabled=yes

Увімкнути dhcp

ip dhcp-client add interface=ether1 disabled=no

Прописати статичні налаштування

ip addr add interface=ether1 address=ір/маска

Прописати маршрут по замовчуванню

На ІР працює в будь-якому випадку, але така схема буде проблемою, якщо провайдер змінює шлюз без вашого відома. На порт працює лише в тому варіанті, якщо на стороні провайдера і у вас на порту присутнє ввімкнення автоматичного додавання ІР в ARP таблицю. Якщо на одній з сторін АRP прив'язки вимкнені тоді схема маршруту по порту не працюватиме.

На інтерфейс

ip route add dst-address=0.0.0.0/0 gateway=ether0

На ір

ip route add dst-address=0.0.0.0/0 gateway=ір

- де ір - шлюз провайдера

Видалення маршрутів

Щоб видалити маршрут ввести вказати команду

ip route remove 0

Де 0 - номер маршруту, дізнатись його можна командою

ip route print

Налаштувати dhcp

Обрати пул адрес, що будуть видаватись

Можна вказати всю підмережу

ip pool add name=dhcp-pool ranges=172.16.13.0/24

Або ж вказати конкретний діапазон

ip pool add name=dhcp-pool ranges=192.168.15.101-192.168.15.200
ip dhcp-server add address-pool=dhcp-pool disabled=no interface=ether2 lease-time=1d name=dhcp-server1
ip dhcp-server  network add address=172.16.13.0/24 dns-server=
172.16.13.0 gateway=172.16.13.0 netmask=24

Налаштовуємо NAT (masquerade / маскарадинг)

ip firewall nat add chain=srcnat action=masquerade out-interface=ether1

Якщо потрібно зробити прокид певного порта тоді

/ip firewall nat add chain=dstnat dst-port=1234 action=dst-nat protocol=tcp to-address=192.168.1.1 to-port=1234

https://wiki.mikrotik.com/wiki/Manual:IP/Firewall/NAT

Інформаційні команди


  • /export compact
  • ip route print
  • ip route print detail
  • ip address print
  • ip address print detail
  • ip pool print

Команди

  • ip pool remove 0
  • ip firewall nat add chain=srcnat action=masquerade out-interface=ether1

Привести до ладу

По умолчанию для входа используется логин admin без пароля. Добавление пользователя:

use add name=имя password=пароль group=full

Отключаемся чтобы зайти под новым пользователем:

quit

Отключение пользователя:

user disable admin

Просмотр пользователей:

user print

 Интерфейсы MikroTik CLI

Просмотр интерфейсов:

interface print

Активация интерфейса:

interface enable 0

Назначение интерфейсу IP адреса:

ip address add address 172.17.1.199/24 interface ether1

Просмотр IP адресов:

ip address print

Изменение MTU интерфейсов:

interface set 0,1,2 mtu=1500

Изменение mac адреса интерфейса:

/interface ethernet set ether1 mac-address=00:01:02:03:04:05

Сброс mac адреса интерфейса:

/interface ethernet reset-mac ether1

Установка шлюза по умолчанию:

ip route add gateway=172.16.1.131

Просмотр маршрутов:

ip route print

Устанавливаем первичный и вторичный адреса DNS серверов:

ip dns set primary-dns=8.8.8.8 secondary-dns=8.8.4.4 allow-remote-requests=yes

Просмотр DNS параметров:

ip dns print

Беспроводные интерфейсы MikroTik

Просмотр беспроводных интерфейсов:

/interface wireless print

Установка времени в MikroTik CLI

Установка часового пояса:

system clock set time-zone=+2

Установка ip адреса ntp сервера с которым будет сверяться время:

system ntp client set enabled=yes primary-ntp=172.16.1.131

Просмотр времени:

/system clock print

Настройка Firewall MikroTik CLI

Настройка маскарадинга, чтобы чтобы внутренняя сеть не была видна с WAN порта:

ip firewall nat add chain=srcnat action=masquerade out-interface=интерфейс провайдера

Просмотр правил:

ip firewall filter print

Пример ограничения количества соединений с одного IP:

/ip firewall rule forward add protocol=tcp tcp -options=syn-only connection-limit=5 action=drop

Пример блокировки всех TCP пакетов идущих на порт 135:

/ip firewall rule forward add dst -port=135 protocol=tcp action=drop

Пример проброса портов:

/ip firewall dst-nat add action=nat protocol=tcp dst-address=10.0.0.217/32:80 to-dst-address=192.168.0.4

Системные настройки MikroTik и информация в консоли

Просмотр стандартных настроек:

/system default-configuration print

Сброс настроек:

/system reset-configuration

Просмотр истории:

/system history print

Службы MikroTik

Просмотр служб:

/ip service print

Прочая информация по коммандрой строке MikroTik CLI

Переход на уровень выше:

/

Выполнение команды из другого уровня без смены текущего:

/.

Помощь:

?

Настройка маршрутизатора с помощью мастера настроек:

setup

Пинг:

ping 192.168.1.2 count 3 size 512

Вход и выход из безопасного режима: Ctrl+X. Мини шпаргалка или памятка по командам для консоли маршрутизаторов MikroTik готова и будет обновляться. Какие комманды используете вы?

Бонус

EoIP тунель

Найпростіший тунель, що працює на білих ір адресах.

interface eoip add name=tunel1 tunnel-id=0 remote-address=10.0.24.2 local-address=172.30.10.188 

налаштовуємо роутинг

Discussion

You could leave a comment if you were logged in.
merezhi/mikrotik/bazove_nalashtuvannja_z_komandnogo_rjadka.txt · Востаннє змінено: 2021/01/29 15:03 повз Юрій